Open Forum

Like what you see? Discover the benefits of the GPUG Community. Learn More

GP2015 lost custom links when an update was installed for Windows10 or Office365

  • 1.  GP2015 lost custom links when an update was installed for Windows10 or Office365

    GOLD CONTRIBUTOR
    Posted 11 days ago
    ​GP2015 lost custom links when an update was installed for Windows10 or Office365, we already had Windows10 & Office 365 working and custom links showing on this computer.  This was not from switching to Windows10 or Office 365, but from their most currently installed update.

    Anyone else have this problem.

    ------------------------------
    Debbie Cummings
    Accounting Systems Manager/Analyst
    Excell Marketing LC
    Des Moines, IA, USA
    ------------------------------


  • 2.  RE: GP2015 lost custom links when an update was installed for Windows10 or Office365

    SILVER CONTRIBUTOR
    Posted 10 days ago
    I have a similar issue with one user where she was booted out of GP and when she went back in her Home Page settings were gone and she had to add them back.  She recently was upgraded to Windows 10 but so were my other users and no one else has had this issue.  Any ideas why this happens?

    ------------------------------
    Theresa Rago
    Manager, Financial Systems
    CV Starr & Co, Inc.
    New York NY
    ------------------------------



  • 3.  RE: GP2015 lost custom links when an update was installed for Windows10 or Office365

    GPUG ALL STAR
    Posted 9 days ago
    Hi @Theresa Rago,

    Were all the settings gone or just the quick links ?  I recall cases were I couldn't even get back the various 'panes' on the home page, no matter how many times you try to select them in the 'Customize this page... ' settings..  Check - Uncheck - reCheck, tried them all..  Setting the user with a new 'home' page role would basically reset all, but also wipe out their quick links.

    At the end, deleting all the entries for the user account in the SY08100 table would force GP to set them back after the user gets back into GP..  Running the command below when the user is not in GP would wipe out the home page settings and resets them.

    Delete DYNAMICS..SY08100​ where userid = 'bad user'

    Deleting those entries for that user will simply reset the home page to the default layout in GP (To do, Connect, My Reports, Quick Links).. The Quick Links settings are not lost by this operation, nor are the 'My Reports' settings. It's just the layout of the home page.
    The user can then go back into the 'Customize This Page.. ' and select / unselect the options to display.


    ------------------------------
    Beat Bucher
    Business Analyst, Dynamics GP SME
    Montreal QC/Canada
    @GP_Beat http://www.gp-geek.com
    Montreal QC GPUG Chapter Leader
    MBS MVP (2015-2018)
    ------------------------------



  • 4.  RE: GP2015 lost custom links when an update was installed for Windows10 or Office365

    SILVER CONTRIBUTOR
    Posted 10 days ago
    Hi,

    The user shortcuts are stored in the Dynamics SY01990 and quicklinks are in the SY08140; I would interrogate those tables and and SQL server logs to see if something happened there.

    I have seen instance where user accounts in Dynamics become corrupted over the years and have had to recreate them and using these tables to extract the existing shortcuts and links and then add them to the new profile is helpful for the user.

    While I wouldn't dismiss completely that an OS or parasitic application patch might cause issues in Dynamics, what you describe doesn't make logical sense for me.

    I would query the user and determine if they had any other incident(s) with Dynamics in the time period prior to the loss of the shortcuts.

    I hope this helps.


    ------------------------------
    Tim Andaya
    Strategic Systems Group
    "There are no stupid questions."
    ------------------------------



  • 5.  RE: GP2015 lost custom links when an update was installed for Windows10 or Office365

    TOP CONTRIBUTOR
    Posted 9 days ago
    Hi @Debbie Cummings  and all.

    This is kind of a tricky one and it happens more often than anyone likes to talk about.

    There is a fix, but it will need to be done by your IT System Admin or your partner.

    Please refer to this article for the fix:

    https://community.dynamics.com/gp/f/32/t/119295?pi62033=1#responses

    It will require some scripts to be run in SQL.​​

    ------------------------------
    Kindest Regards,

    Jo deRuiter , MCP, DCP
    "That GP Red Head"
    Advanced Credentialed Professional-Dynamics GP
    GPUG Academy Instructor
    GPUG GP Credentialing Exam Committee
    Chairman, GPUG Partner Advisory Board
    Dexpro Dynamics LLC
    Senior Consultant
    Milwaukee, WI
    770-906-4504 (Cell)
    ------------------------------