Open Forum

Like what you see? Discover the benefits of the GPUG Community. Learn More

1.  GP 2016 web Installation using Organizational Account

SILVER CONTRIBUTOR
Posted 7 days ago
  |   view attached

Hi,

I am doing an Scale Out Installation of GP Web client 2016, using organizational account. However, after getting all configurations I am getting error (As attached), while creating a session first time.


Experts advice needed.

Kind Regards.



------------------------------
Irfan Rasheed
Staff ERP Executive
Avanceon limited
Lahore
------------------------------


2.  RE: GP 2016 web Installation using Organizational Account

TOP CONTRIBUTOR
Posted 6 days ago
I'm familiar with service accounts and user accounts for software installs, but not "organizational accounts".  Typically, you can't use any kind of "group" account such as a Distribution Group or Security Group to do a software install.  Can you elaborate?

------------------------------
Blair Christensen
Database Administrator
Oppenheimer Companies, Inc.
Boise ID
------------------------------



3.  RE: GP 2016 web Installation using Organizational Account

SILVER CONTRIBUTOR
Posted 5 days ago
Edited by Irfan Rasheed 5 days ago

Hi Blair,

Today I have created a fresh environment for GP Web Client Scale Out Installation, as per below:

01 ERP Server:           GP & SQL Databases

01 Web Server:         WebSite, Session Central Service, GP Service

02 Session Servers:   Session Service, Dexterity Service Control, Client GP with WebClient Runtime

All process went smooth. I successfully verify Web Management Console, but when I tried to create a session. it prompts up a different error from Web Server. Error as below:


Interestingly, when i try to create session from Session Server, I get another error as below:

I dig into Events Viewer of Web Server, where below message appears:


Please guide the missing link. 

Kind Regards.



------------------------------
Irfan Rasheed
Staff ERP Executive
Avanceon limited
Lahore
------------------------------



4.  RE: GP 2016 web Installation using Organizational Account

TOP CONTRIBUTOR
Posted 5 days ago
​Again, what type of user are you employing to create all these services?

In my experiences with web services, it matters what kind of user is being used to do the installs and set up the services.  In some cases, you can use a Service Account, in others you have to use an actual User account with certain administrative privileges.  I've never been able to use any kind of group account, however.

------------------------------
Blair Christensen
Database Administrator
Oppenheimer Companies, Inc.
Boise ID
------------------------------



5.  RE: GP 2016 web Installation using Organizational Account

SILVER CONTRIBUTOR
Posted 5 days ago
I am using organizational account, not windows account. Main purpose is to get benefit single sign on for office 365.

I have added a GP web app in azure domain and then configure organizational accounts using manage user authentication from GP utilities.



------------------------------
Irfan Rasheed
Staff ERP Executive
Avanceon limited
Lahore
------------------------------



6.  RE: GP 2016 web Installation using Organizational Account

SILVER CONTRIBUTOR
Posted yesterday

Alas, I got answers to my queries after a long and tedious R&D.

Error message refer to 'The Value XXXXXXX must be a URI', where URI refers to any website address, it was entered an an value as shown in error message (Attached earlier). I also check that dbo.AzureApplication table from GPCONIFIGURATION database.

I have changed values of APPID URI and reconfigure Web Components and i go through to this message to welcome screen to GP login.

However, Once i provide my O365 credentials, i got below error.

Any thoughts on it? why i am getting this.

Moreover, in user setup window while creating a new user I also not able to use organizational accounts, as it is disabled (as per below image).

Any suggestions on this as well.

Kind Regards.



------------------------------
Irfan Rasheed
Staff ERP Executive
Avanceon limited
Lahore
------------------------------



7.  RE: GP 2016 web Installation using Organizational Account

TOP CONTRIBUTOR
Posted yesterday
I would check and make sure the DYNSA login you are using has the sysadmin role assigned to it under SQL Security  Server Roles.  Or try using login =  sa and see if you get the same results.

------------------------------
Thaddeus Suter
Retus, Inc
TX
------------------------------



8.  RE: GP 2016 web Installation using Organizational Account

SILVER CONTRIBUTOR
Posted yesterday
Same results with sa and dynsa users. No change.

Both granted sysadmin role in SQL server.

------------------------------
Irfan Rasheed
Staff ERP Executive
Avanceon limited
Lahore
------------------------------



9.  RE: GP 2016 web Installation using Organizational Account

TOP CONTRIBUTOR
Posted 7 hours ago
Hi Irfan,
I'm posting here the link from your crossposting on the community forums, as other people may not be aware what solutions have been suggested already so far, but not mentioned here..

https://community.dynamics.com/gp/f/32/t/260691

------------------------------
Beat Bucher
Business Analyst, Dynamics GP MVP
Ultra-Electronics Forensic Technology Inc.
Montreal QC/Canada
@GP_Beat http://dyngpbeat.wordpress.com/
Montreal QC GPUG Chapter Leader
GP2013R2 / MR2012 CU14
------------------------------



10.  RE: GP 2016 web Installation using Organizational Account

SILVER CONTRIBUTOR
Posted 7 hours ago
Thanks Beat.

However, I have plan to upload a whole scenario, both for scale out organizational deployment and aingle machine windows account deployment for the sake of sharing knowledge.

However, currently I am stuck in this error, as mentioned earlier.

Looking for the resolutions.

------------------------------
Irfan Rasheed
Staff ERP Executive
Avanceon limited
Lahore
------------------------------



11.  RE: GP 2016 web Installation using Organizational Account

TOP CONTRIBUTOR
Posted 5 hours ago
I feel your pain..

O365 accounts is supposed to be supported, but I've never tried to deploy GP's Web client with Cloud account authentication..
Hopefully someone will chime in with such experience..
Have you checked Ian Grieve's blog  Azurecurve ? it's a wealth of resources when it comes to the web client :
http://www.azurecurve.co.uk/category/microsoft/microsoft-dynamics/microsoft-dynamics-gp/web-client/page/2/


------------------------------
Beat Bucher
Business Analyst, Dynamics GP MVP
Ultra-Electronics Forensic Technology Inc.
Montreal QC/Canada
@GP_Beat http://dyngpbeat.wordpress.com/
Montreal QC GPUG Chapter Leader
GP2013R2 / MR2012 CU14
------------------------------