Open Forum

Expand all | Collapse all

Defaulting to Dynamics Server on User Login

  • 1.  Defaulting to Dynamics Server on User Login

    Posted 19 days ago
    Morning all,
    I was looking for a way to set the default for the server on the user login to dynamics so that when the user opens up the login screen for GP "Dynamics" is default and prepopulated for the user to just type in their user information and log in.
    Dynamics box is blank for my user and I would like it to be pre-populated.


    This is how is should look like.
    When the user opens dynamics GP they have to choose dynamics from the drop-down instead of it being pre-populated when the screen to login appears.

    is there anyway to default this?

    Thank you all for your help!
    Megan Thomas

    ------------------------------
    Megan Thomas
    Information Systems Manager
    Old Hickory Furniture

    ------------------------------
    Academy - Online Interactive Learning from Experts


  • 2.  RE: Defaulting to Dynamics Server on User Login

    TOP CONTRIBUTOR
    Posted 19 days ago
    You need this statement line in your dex.ini file:

    SQLLastDataSource=Dynamics

    ------------------------------
    Thaddeus Suter
    Retus, Inc
    HELOTES TX
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 3.  RE: Defaulting to Dynamics Server on User Login

    Posted 19 days ago
    On this users computer, the dex.ini is already reading
    SQLLastDataSource=Dynamics
    However, it still does not show the prepopulated server choice.

    ------------------------------
    Megan Thomas
    Old Hickory Furniture
    Rusvhille IN
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 4.  RE: Defaulting to Dynamics Server on User Login

    TOP CONTRIBUTOR
    Posted 19 days ago
    GP2013 and later has per user capability by  EnablePerUserIni=TRUE

    Thus you will want to query the DYNAMICS SY01405 table to verify that DYNAMICS is the iniKeyValue for SQLLastDataSource as you see below for that user.
    You may however want to update it for all users.


    ------------------------------
    Thaddeus Suter
    Retus, Inc
    HELOTES TX
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 5.  RE: Defaulting to Dynamics Server on User Login

    Posted 19 days ago
    This would probably work but we are using GP 8.0.

    ------------------------------
    Megan Thomas
    Old Hickory Furniture
    Rusvhille IN
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 6.  RE: Defaulting to Dynamics Server on User Login

    TOP CONTRIBUTOR
    Posted 19 days ago
    Oh no...sorry I'm not going to be able to assist on that. I'd say somebody got their moneys worth on V8.0 though. Have not seen that in a few years. In 2016, I did a direct 24hr update V9.0 to V2016R2 and from SQL2005 old server to SQL2016 new server for a company in Indianapolis.
    I must say it was a bit of a chore....and took a couple dry runs.

    ------------------------------
    Thaddeus Suter
    Retus, Inc
    HELOTES TX
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 7.  RE: Defaulting to Dynamics Server on User Login

    GPUG ALL STAR
    Posted 16 days ago
    @Megan Thomas

    v8.0 was released on ​02-June-2004. I really think it is time for this site to upgrade.

    A lot has changed in the last 16 years.

    FYI: Once the ODBC setting is stored in the Dex.ini it will be remembered.

    Regards

    David

    ------------------------------
    David Musgrave MVP, GPUG All-Star

    Managing Director
    Winthrop Development Consultants

    Perth, Western Australia

    http://www.winthropdc.com
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 8.  RE: Defaulting to Dynamics Server on User Login

    Posted 16 days ago
    Check the name of the ODBC data source and verify it is indeed Dynamics without preceding or following spaces. The data source is likely not matching what the Dex.ini file is referencing.

    ------------------------------
    Constance Quigley
    Dynamic Budgets
    wimberley TX
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 9.  RE: Defaulting to Dynamics Server on User Login

    TOP CONTRIBUTOR
    Posted 15 days ago
    Wow, 8.0  that takes me back!
    I agree with Constance, spaces in the ODBC name before or after have caught me a time or two.
    • Also the other common ODBC issues, 32-bit ODBC not 64-bit.
    • Do you have more than one 32-bit ODBC listed in Windows? GP Server Pull-down see more than one option?
    • Check the SQL Driver version. If you are trying to use a 11.0 version driver, I am not sure but  GP 8.0 might not like it.
    • Any mix of (more) modern Windows Server etc. and GP 8.0 might cause issues.
    • Another good reason to update GP, Windows, & SQL, all are way out of support.


    ------------------------------
    David Morinello
    Senior Dynamics GP Systems Architect
    Ascend Learning, LLC
    Leawood KS
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 10.  RE: Defaulting to Dynamics Server on User Login

    GPUG ALL STAR
    Posted 15 days ago
    @Megan Thomas

    Have you confirmed that the ODBC settings created is a 32 bit System Data Source​ created with the 32 bit tool.

    If your Administrative settings does not have a ODBC 32 bit link, you can create one to the 32 bit tool in the following location

    C:\Windows\SysWOW64\odbcad32.exe

    Regards

    David

    ------------------------------
    David Musgrave MVP, GPUG All-Star

    Managing Director
    Winthrop Development Consultants

    Perth, Western Australia

    http://www.winthropdc.com
    ------------------------------

    Academy - Online Interactive Learning from Experts


If you've found this thread useful, dive deeper into User Group community content by role