Open Forum

Expand all | Collapse all

Smartlist Builder Error

  • 1.  Smartlist Builder Error

    TOP CONTRIBUTOR
    Posted Mar 07, 2018 11:59 AM
    ​Hi There,

    I am receiving error below when I try to open smartlist. Is there anything I could do to turn this off ?
    We have not done any upgrades to smartlist or smartlist builder.

    Please advise!
    Thanks!



    ------------------------------
    Sunaina Sharma, Business Application Analyst(Admin)
    Oakville Enterprise Corporation
    ------------------------------
    Conference-GPUG_200x200


  • 2.  RE: Smartlist Builder Error

    GPUG ALL STAR
    Posted Mar 07, 2018 01:06 PM

    ​Hi @Sunaina Sharma

    You need to log in to GP as the 'sa' and enter the registration keys for SmartList Builder.

    You can enter them at Microsoft Dynamics>Tools>SmartListBuilder>​Register SmartList Builder

    If you don't have keys, contact eOne to obtain them.

    ------------------------------
    Regards,

    Jo deRuiter
    "That GP Red Head"
    Senior Financial Systems Consultant
    Heartland Business Systems, LLC
    Milwaukee, WI
    770-906-4504 (Cell)
    ------------------------------

    Conference-GPUG_200x200


  • 3.  RE: Smartlist Builder Error

    TOP CONTRIBUTOR
    Posted Mar 07, 2018 01:41 PM
    ​Hi Jo,

    I see reg keys are already  there. So there is nothing for me to enter. Is there a chance that may be these keys have expired?

    thanks!
    Sunaina

    ------------------------------
    Sunaina Sharma, Business Application Analyst(Admin)
    Oakville Enterprise Corporation
    ------------------------------

    Conference-GPUG_200x200


  • 4.  RE: Smartlist Builder Error

    GPUG ALL STAR
    Posted Mar 07, 2018 01:47 PM
    ​Good Afternoon, @Sunaina Sharma


    You mentioned you had not done any upgrades, so that has me wondering.   It IS possible that the registration keys are invalid - I would think that would be a different message.


    My advice is to call eOne or log in to them if you have a login and generate new keys.  If the new keys fail then you likely have a bigger problem


    Here is a great post by @Ian Grieve outlining some troubleshooting - this really on deals with upgrades though, so if you are still unsure please contact your GP Partner.

    SmartList Builder Will Be Disabled Until It Is Initialized By The System Administrator - Microsoft Dynamics GP Community
    Dynamics remove preview
    SmartList Builder Will Be Disabled Until It Is Initialized By The System Administrator - Microsoft Dynamics GP Community
    I have been involved in several upgrade projects with clients recently where we have been upgrading them from Microsoft Dynamics GP 2010 through to Microsoft Dynamics GP 2013. Since this version was launched, SmartList Builder has been pushed back out to eOne, the original ISV.
    View this on Dynamics >




    ------------------------------
    Regards,

    Jo deRuiter
    "That GP Red Head"
    Senior Financial Systems Consultant
    Heartland Business Systems, LLC
    Milwaukee, WI
    770-906-4504 (Cell)
    ------------------------------

    Conference-GPUG_200x200


  • 5.  RE: Smartlist Builder Error

    TOP CONTRIBUTOR
    Posted Mar 08, 2018 09:13 AM
    This error generally indicates that SmartList Builder thinks something needs to be updated.  Whether it be you did install a new workstation and it has a different build, you updated from a previous release, etc.  Whatever it is finding that needs to be updated, it cannot do it unless you log in as 'sa'.  So, my recommendation is to log in as 'sa' and then let it try to do what is needed.  Then log in as your standard user and see if you still get the message.  If you do, a DexSQL.log or a SQL Trace (with errors turned on), it should show what it is trying to update and failing on.  If you aren't sure, I would recommend contacting the eOne support team by emailing them at support@eonesolutions.com and they can help read the log/trace and figure out what is going on.




    ------------------------------
    Nicole Albertson
    Product Manager
    eOne Solutions
    ------------------------------

    Conference-GPUG_200x200


  • 6.  RE: Smartlist Builder Error

    TOP CONTRIBUTOR
    Posted 7 days ago
    Make sure you have the latest version of Smartlist installed:
    from eone support:
    Login to GP and go to Tools - SmartList Builder - About SmartList Builder.  See what version of SLB they have installed.  The version is over on the right.

    If they are on GP 2016, the version should say something like 16.00.0037

    Rename SLBUILD.DIC in the GP folder, then install the 16.00.0037 msi program.  You won't need new keys or anything. 



    ------------------------------
    Bruce Strom
    Programmer Analyst
    Superior Lighting, Inc.
    Sunrise FL
    ------------------------------

    Conference-GPUG_200x200


If you've found this thread useful, dive deeper into User Group community content by role