Open Forum

  • 1.  Exchange Log On Fails

    Posted Oct 26, 2021 01:42 PM
    Edited by Magdalena Swiderski Oct 26, 2021 01:43 PM
    Hello,
    Our users recently started experiencing an issue with Exchange Log On. Usually they're prompted to login to Exchange when they need to use the email function or update record with email for the first time after logging in to Great Plains in the morning.  And it's worked fine for years. Recently, however, when they get prompted to login to Exchange, they get "Login Failed: check your login information and try again"  as if they didn't type in correct information. We are 100% sure the email, password, and Login ID are correct. The user is not locked in AD or GP. We did not make any recent changes in any email settings in GP. There's no reason why they can't login. They are unable to send emails from GP, which is a big productivity issue.
    We're on GP 2018 with Office 365.
    Please help.​

    ------------------------------
    Magdalena Swiderski
    Beekley Corporation
    BRISTOL CT
    ------------------------------
    Academy - Online Interactive Learning from Experts


  • 2.  RE: Exchange Log On Fails

    TOP CONTRIBUTOR
    Posted Oct 27, 2021 08:24 AM
    Check to see if your IT changed Exchange settings. There are many discussions here on Office and MFA authentication. We have GP 2018 R2 and ended up temporarily downgrading to Office 2013. FYI, newer GP versions now support Office with MFA.

    Dynamics GP & Exchange End of Support Plans? | Open Forum (gpug.com)
    Multi-Factor Authentication - Dynamics GP | Microsoft Docs

    ------------------------------
    David Morinello
    Senior Dynamics GP Systems Architect
    Ascend Learning, LLC
    Leawood KS
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 3.  RE: Exchange Log On Fails

    Posted Oct 27, 2021 08:39 AM
    I have seen the posts about Multi-Factor Authentication​, but that doesn't apply to us. We do not have that turned on.

    ------------------------------
    Magdalena Swiderski
    Beekley Corporation
    BRISTOL CT
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 4.  RE: Exchange Log On Fails

    GOLD CONTRIBUTOR
    Posted Oct 27, 2021 12:28 PM
    Hi Magdalena,
    Have there been any changes to your domain name or email hosting.  If you have or even if not, clearing the SY04920 table in the Dynamics database will help at times with the authentication.


    ------------------------------
    John Kirsch
    GP Product Lead
    Dynamic Consulting
    Green Bay WI
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 5.  RE: Exchange Log On Fails

    GPUG ALL STAR
    Posted Oct 27, 2021 03:33 PM
    Magdalena,
    As one of Terry's link might suggest, Microsoft apparently decided to progressively disable the TLS 1.0 protocol on all Online-Exchange servers in the cloud by 10/15/2021, which might be the reason why suddenly several customers are running into this issue. Most of them being on older GP 2016 or 2018 builds, this would make sense.
    At the same time it means that you might be forced to upgrade GP to get compliant with TLS 1.2 or 2.0

    https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/opt-in-exchange-online-endpoint-for-legacy-tls-using-smtp-auth



    ------------------------------
    Beat Bucher
    Business Analyst, Dynamics GP SME
    Montreal QC/Canada
    @GP_Beat http://www.gp-geek.com
    Montreal QC GPUG Chapter Leader
    MBS MVP (2015-2018)
    All-Star 2013
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 6.  RE: Exchange Log On Fails

    GPUG ALL STAR
    Posted Oct 27, 2021 01:03 PM

    With Login Failed type of error message we have seen some cases where TLS 1.0 was disabled, due to the looming end date and vulnerabilities.

    I would make sure on your local exchange servers you have TLS 1.0 enabled.

    (+) Microsoft Dynamics GP Fall 2020 - TLS 1.2 - Microsoft Dynamics GP Community


    Here is also an article about when they plan to disable TLS in 2022

    Opt in to the Exchange Online endpoint for legacy TLS clients using SMTP AUTH | Microsoft Docs


    Thanks
    Terry Heley
    Microsoft



    ------------------------------
    Terry Heley
    HR/PR expert
    Microsoft
    West Fargo ND
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 7.  RE: Exchange Log On Fails

    GPUG ALL STAR
    Posted Oct 27, 2021 03:05 PM
    Terry,
    I have 2 customers in total different regions (Est & mid-west) that started having issues with e-mailing out of GP, randomly out of the blue, with no hint on where to look for a fix, as nothing had changed on their systems or in GP.
    The kind of issues related to TLS are hard to tackle as we don't know where to look for the problem.. The "Exchange" option in GP acts like a black box and we don't have any control on what it does..
    Many times the Network guys (or IT) come back and say they haven't changed anything in the systems, nor were any updates applied, though this has to be double-checked if there weren't any 'updates' on Windows applied secretly, unbeknownst to them.
    I find it a strange coincidence that those kind of issue occur all at the same time, and I'd tempted to say the problem is on the Microsoft side (as it affects Office 365 logins).

    ------------------------------
    Beat Bucher
    Business Analyst, Dynamics GP SME
    Montreal QC/Canada
    @GP_Beat http://www.gp-geek.com
    Montreal QC GPUG Chapter Leader
    MBS MVP (2015-2018)
    All-Star 2013
    ------------------------------

    Academy - Online Interactive Learning from Experts


If you've found this thread useful, dive deeper into User Group community content by role