Open Forum

Expand all | Collapse all

Errors when creating a test environment for GP 2018

  • 1.  Errors when creating a test environment for GP 2018

    Posted Nov 11, 2019 06:43 PM
    Hi,

    I am attempting a separate SQL server instance test environment for #GP2018and2018R2

    The SQL server is a clone of the production, in that the same folder structures, permissions, and updates ​are applied.
    We utilize an App server for management reporter services and file repository.

    Starting from the beginning, I have setup the SQL server to MS recommendations, as well as, copying our prod SQL server settings.

    I am installing the first GP client on the App server and allowed for setup to create the ODBC driver with mostly everything default.
    After installed I launch GP utilities and choose defaults with basic framework, and no web client config.

    I verified the ODBC connection is correct and folder permissions for GP are set to allow full control for all users.

    When launching the GP client, I am prompted to run GP utilities, after running utilities (again), I "launch GP" and after inputting sa password, I am prompted to launch GP utilities.

    I cannot launch GP without needing to redo GP utilities, this has happened numerous times now.

    Synchronization = FALSE on the dex file... I am unsure where to go from here. This was supposed to simple!


    ------------------------------
    Nicholas Rau
    QC Holdings, Inc.
    Overland Park KS
    ------------------------------
    Conference-GPUG_200x200


  • 2.  RE: Errors when creating a test environment for GP 2018

    GPUG ALL STAR
    Posted Nov 12, 2019 01:14 AM
    Edited by David Musgrave Nov 13, 2019 01:34 AM
    @Nick Rau

    Dynamics Utilities will also launch if Initial=TRUE as well as Synchronize=TRUE

    If setting up a test environment, I would look to copying the application folder from a live install client to you test environment to get all the same settings. Also backup and restore databases. Then change the ODBC source or make sure the source points to the test server.

    You can also use GP Power Tools' Database Validation tool to fix all the logins and clean up any references to users or companies not being used in the test environment.

    Regards

    David

    ------------------------------
    David Musgrave MVP, GPUG All-Star

    Managing Director
    Winthrop Development Consultants

    Perth, Western Australia

    http://www.winthropdc.com
    ------------------------------

    Conference-GPUG_200x200


  • 3.  RE: Errors when creating a test environment for GP 2018

    Posted Nov 12, 2019 10:25 AM
    Thanks David I will try this approach and see if I get better results.

    ------------------------------
    Nicholas Rau
    QC Holdings, Inc.
    Overland Park KS
    ------------------------------

    Conference-GPUG_200x200


  • 4.  RE: Errors when creating a test environment for GP 2018

    Posted Nov 12, 2019 08:53 AM
    Hi Nicholas,
    When we built out our test environment I remember having to run GP as admin the first time and run the utilities that way.  Otherwise it would never stick.  Are you running GP as admin perhaps?

    Thanks,

    ------------------------------
    Dave Magalen
    Aurora Plastics, Inc
    Streetsboro, Oh
    ------------------------------

    Conference-GPUG_200x200


  • 5.  RE: Errors when creating a test environment for GP 2018

    Posted Nov 12, 2019 10:24 AM
    Hi Dave,

    Yes, I have been running as admin. Which is a bummer, I wish it would be that simple!

    ------------------------------
    Nicholas Rau
    QC Holdings, Inc.
    Overland Park KS
    ------------------------------

    Conference-GPUG_200x200


If you've found this thread useful, dive deeper into User Group community content by role