Open Forum

Like what you see? Discover the benefits of the GPUG Community. Learn More

Workflow - Email test failing

  • 1.  Workflow - Email test failing

    Posted 12 days ago
    Hi,
    We've been looking into implementing workflow at our company and therefore started looking into all the features it has to offer. Right now the email test is not working for some reason. We send out remittances and order confirmations without any problem so not sure what's preventing this feature from working. Any help would be greatly appreciated
    test

    ------------------------------
    Karl Solski
    MIP Inc.
    Anjou QC
    ------------------------------


  • 2.  RE: Workflow - Email test failing

    SILVER CONTRIBUTOR
    Posted 11 days ago
    Karl, you need to have a Web Services server running to utilize Workflow, and there's none listed in your screenshot.

    ------------------------------
    Charles Ray
    Senior Systems Specialist
    CAL Business Solutions, Inc.
    Harwinton CT
    ------------------------------



  • 3.  RE: Workflow - Email test failing

    Posted 11 days ago
    GP 2018 R2- I had trouble setting it up as well.

    Here is the Gmail setup information they tested and furnished to me:
        -- SMTP Server:  smtp.gmail.com
        -- SMTP Port Number: 465
        -- SMTP TLS/SSL required?  Yes
        Under 'Basic Authentication' you would need to have the GMail email account and passwords entered.

    To make things more difficult, workflow email will not work with Office 365 SMTP with MFA- even though that sends just fine in other modules. Just not workflow. So, this new and improved feature requires us to use Gmail or Outlook.com if you have MFA set up- and implementing MFA is a best practice.






    ------------------------------
    Michael Bartlett
    Quantum Marine Engineering of Florida, Inc.
    Fort Lauderdale FL
    ------------------------------



  • 4.  RE: Workflow - Email test failing

    TOP CONTRIBUTOR
    Posted 11 days ago
    GP 2018R2, GP2016R2 . You can run workflow just fine with email notifications
    1. document submitted
    2. document  rejected
    3. document approved
    4.......
    Emails sent as each event occurs.

    without checking the bottom box for Email Actions.

    Email Action only works in GP2018R2. Not GP2016R2. See red circle below

    Email Action are to put "action lines" in the email body allowing the recipient to:
    1.View
    2. Reject
    3. Approve....
    Without being logged into GP or the Web Client. Ie, do the action from their email.

    However you do not want to mark "This server requires a secure Connection (SSL) because Microsoft Web Services which must be installed for these Email Actions does NOT SUPPORT SSL.  It is HTTP not HTTPS and you can't config it to HTTPS in IIS.

    If you do not mark the box, Emails Actions in GP2018R2 it will work, but your users must be on the network or have their VPN connected for the link to work in their email. No SSL.

    This spoils their ability to approve Documents by email from their phones. MS Web Services has been around a while but was never designed for SSL (HTTPS) connections only HTTP.

    If you want that iPhone to be able to approve and reject docs, , plan on some serious technical work outside of IIS to convert your HTTP Web Services to HTTPS.

    ------------------------------
    Thaddeus Suter
    Retus, Inc
    HELOTES TX
    ------------------------------



  • 5.  RE: Workflow - Email test failing

    Posted 11 days ago
    Your gmail settings look to be off a bit, maybe take a look at them.
    Here is some basic settings.  You can get gmails info on non-authenticated accounts as well.



    ------------------------------
    Allen Schierholz
    System Administrator
    Forum Communications Company
    Fargo ND
    ------------------------------



  • 6.  RE: Workflow - Email test failing

    SILVER CONTRIBUTOR
    Posted 11 days ago
    If the Test Emails aren't working then more times than not your SMTP information in the Workflow Setup window is not correct.

    Web Services actually is not needed at all to use Workflow, unless you want users to have the ability to take action (approve, reject, delegate) workflows through the email notifications sent to approvers.

    I think Michael is on the right track as I question port 25 but haven't done a lot of setup using GMAIL accounts or SMTP credentials.

    I know as a test, we often have users setup a new outlook.com email address, then use that along with the following SMTP information to test, which will often work:

    -- E-Mail Address: User@outlook.com
    -- Display Name: User Name
    -- smtp-mail.outlook.com

    -- Port: 587

    -- Mark the option of 'This server requires a secure connection (SSL).'

    This would at least help verify that it is the GMAIL information being entered for the SMTP setup.


    You can also run the 'EXEC wfDeployClrAssemblies' script against your DYNAMICS/system database which will drop and re-create the objects that Workflow uses, including the procedures used for the test and actual workflow emails.


    If you believe you have the SMTP information setup correctly but the Test Emails still don't work, you can try this test as well:

    a. Download the EWSEditor tool from CodePlex at this link: https://ewseditor.codeplex.com

         Extract the files for EWSEditor and right-click on the 'EWSEditor' application and use 'Run As Administrator'.

    b. Click OK on the 'About EWSEditor' window.

    c. In the EWSEditor, click on File > New Exchange Service. In the 'Autodiscover Email' field, enter the email address of the account you have in the Workflow Setup window being used to send emails.

         In the same window, mark the 'Use the following credentials instead of the default Windows credentials' option and then enter the same email address and password that is being used in the Workflow Setup window to send emails. Leave the Domain field blank.

    d. Click OK

         --If the login is successful, you'll get the message asking "Do you want to automatically add the mailbox root to the tree view". You can close this window or click Yes and expand the folders.

         --If the login fails, you'll get an error message talking about 'The Autodiscover service couldn't be located.'. This indicates that there is something not setup correctly with the SMTP information being used in the Workflow Setup window.


    Let us know how it goes.

    Thanks,

    ------------------------------
    Derek Albaugh
    Sr. Support Engineer
    Microsoft
    Moorhead MN
    ------------------------------



  • 7.  RE: Workflow - Email test failing

    Posted 11 days ago
    First of all thank you so much for all the help and suggestions.
    Regarding my screenshot I forgot to uncheck the "Enable Email Actions". I was trying different things and left it in there by accident. Right now the Email Test isn't working so I haven't even bothered looking into the Email actions. We currently don't have web services installed but from what I understand these aren't required for simple email notifications.
    I've tried all the suggestions but still haven't managed to make it work. So I'm pretty much at the stage where I will try the EWSEditor tool and go from there.

    ------------------------------
    Karl Solski
    MIP Inc.
    Anjou QC
    ------------------------------