Open Forum

Expand all | Collapse all

SSRS reports not launching from GP

  • 1.  SSRS reports not launching from GP

    Posted Feb 19, 2020 11:56 AM
    We are experiencing  a random problem where a user suddenly cannot launch SSRS reports.  All users are in a Citrix environment with roaming profiles.  A user will be fine one day and suddenly they cannot get to the reports.  The only solution we have found to this point is to delete the profile from the citrix servers and remove the roam profile and then have the user login to recreate it and everything works again.  Has anyone seen this problem and have a better or easier fix?

    Thanks,

    ------------------------------
    Dave Ahalt
    Sr Business Analyst
    AFL Hyperscale
    Kent WA
    ------------------------------


  • 2.  RE: SSRS reports not launching from GP

    GPUG ALL STAR
    Posted Feb 19, 2020 12:03 PM
    Hi Dave,
    Could you be more explicit with the statement [.. a random problem where a user suddenly cannot launch SSRS reports. ] ?
    SSRS being a web based interface, when GP calls a report, it is supposed to jump over and open the default Web Browser (IE for example) and use the Windows Authentication mode to run the report.
    At which point does the report launch fail ? do you get any specific error message ? or is just nothing happening ?

    ------------------------------
    Beat Bucher
    Business Analyst, Dynamics GP SME
    Montreal QC/Canada
    @GP_Beat http://www.gp-geek.com
    Montreal QC GPUG Chapter Leader
    MBS MVP (2015-2018)
    All-Star 2013
    ------------------------------



  • 3.  RE: SSRS reports not launching from GP

    Posted Feb 19, 2020 12:18 PM
    Hi Beat,

    Nothing happens.  There is no visible attempt to launch and no error message.  Looking at the process monitor or Report Processing status both are empty.  We have not seen a specific event prior to this stopping.  It also does not appear to isolated to a specific Citrix server either.  As a workaround I have given the users the path to the SSRS reports and reports are working for them external to GP.  I am 90% sure this is related to something in the citrix profile for the user since remove and recreate fixes it.  I am trying to find root cause and a permanent fix if possible.

    Dave

    ------------------------------
    Dave Ahalt
    Sr Business Analyst
    AFL Hyperscale
    Kent WA
    ------------------------------



  • 4.  RE: SSRS reports not launching from GP

    TOP CONTRIBUTOR
    Posted Feb 20, 2020 10:53 AM
    Hi Dave!
    We are testing new Citrix servers, finally getting off the old out-of-support Citrix running on Windows 2008 VMs. We definitely see random user profile issues here, but not the type you are seeing with GP launched SSRS reports.

    New Citrix Testing - We are seeing some teething problems with Citrix Workspace (v19.11.0.50) which replaced Citrix Receiver. Some issues we are seeing may also be because the new Citrix servers are Windows 2016 based and GPO settings may need to be tweaked. GP shutdowns, Printing issues; we are still nailing these down before switching over.

    Like Beat said, I suspect GP is not launching the browser window to get to the AD authenticated SSRS Report.
    1. Maybe use GPPT tool to check the Dexterity calls, up to the failure point? What is the last call when it fails? When it succeeds?
    2. Check browser settings on the Citrix boxes?
    3. Have your Citrix guru do a deeper dive into the Citrix servers, especially if anything has been recently updated. GP is probably not breaking here, but is hostange to the settings and stability of the Citrix install.


    ------------------------------
    David Morinello
    Senior Dynamics GP Systems Architect
    Ascend Learning, LLC
    Leawood KS
    ------------------------------



  • 5.  RE: SSRS reports not launching from GP

    Posted Feb 20, 2020 11:30 AM

    Thanks David.  We are on Workspace for web and the servers are 2012 R2.  It is just odd because a user can be working for months and then in the middle of the day the ability to open SSRS goes away but all other users of the server and farm are fine.  We have seen it for 6 or 7 users over the last couple months and once we wipe their profile and recreate they are running fine again.  Appreciate the feedback.
     

    Dave Ahalt



    ------------------------------
    Dave Ahalt
    Sr Business Analyst
    AFL Hyperscale
    Kent WA
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role